Scheduled for May 19, 2026 at 3:00 PM – 7:00 PMUTC
Affects
Updates
Completed
May 19, 2026 at 7:00 PMUTC
Completed
May 19, 2026 at 7:00 PMUTC
Maintenance has completed successfully
In progress
May 19, 2026 at 3:00 PMUTC
In progress
May 19, 2026 at 3:00 PMUTC
Maintenance is now in progress
Planned
May 19, 2026 at 3:00 PMUTC
Planned
May 19, 2026 at 3:00 PMUTC
We're performing hardware replacement on MC.GRA4 and game servers on the affected node will be temporarily unavailable during this window. The hostname/node names will also change during this process but no IP changes will occur.