Scheduled for August 12, 2025 at 2:00 PM – August 19, 2025 at 8:44 PM
Affects
HostVenom
Under maintenance from 2:00 PM to 8:44 PM
WinterNode
Under maintenance from 2:00 PM to 8:44 PM
Control Panels
Under maintenance from 2:00 PM to 8:44 PM
Client Area
Under maintenance from 2:00 PM to 8:44 PM
Completed
August 19, 2025 at 8:44 PMCompleted
August 19, 2025 at 8:44 PMMaintenance has completed successfully.
In progress
August 12, 2025 at 2:00 PMIn progress
August 12, 2025 at 2:00 PMMaintenance is now in progress
Planned
August 12, 2025 at 2:00 PMPlanned
August 12, 2025 at 2:00 PMThis event will not impact customer services.
We're upgrading core infrastructure to improve reliability and performance. During this window, some services may be intermittently unavailable or experience elevated error rates.
Potentially affected services (not exhaustive):
What to expect:
Brief, intermittent interruptions to affected services.
No data loss is expected. If an action fails, please retry after the window.
Updates:
We'll post progress and completion updates under this maintenance notice.