HostVenom & WinterNode - Accessibility Issue with Game Control Panel – Incident details

Accessibility Issue with Game Control Panel

Resolved
Major outage
Started 14 days agoLasted 8 minutes
Updates
  • Update
    Update

    The panel is now back operational.

  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Our panel team has identified the issue and are working on a fix for this incident.